Jump to content

Sujet : SimBrief + A310 show me "Pending"


Cthulhus
 Share

Recommended Posts

20 hours ago, gumbyger said:

If you can open this website and it shows you a file then there is nothing stopping the A310 from importing the flightplan

https://www.simbrief.com/api/xml.fetcher.php?username=XXXXX (XXXXX = your username obviously)

The url works OK for me as well as Simbrief import in other aircraft. But with the A310 I always get "pending" even with empty community folder and no other FS apps running.

Specs: Win 10, AMD Ryzen 7 3700X, 16GB RAM, AMD RX5700, MSFS MS Store (not using beta), Navigraph Unlimited subscription, AIRAC 2211 rev2

Link to comment
Share on other sites

I have the same problem, no SB flightplan is imported. Always pending. my colleague can import flight plans with my SB name without any problems. When comparing the folders, I noticed that no XML file was created for me, but it was in my colleague's folder! That seems to be the problem

 

Link to comment
Share on other sites

29 minutes ago, TIGERM66 said:
it is the folder in which the simbrief.ini is located. My colleague also has a simbrief.xml that contains flight plan data. Which is probably generated during import?

What happens if you simply create a simbrief.xml there and give it write access?

Link to comment
Share on other sites

Mine does not generate an xml either. I created one by downloading https://www.simbrief.com/api/xml.fetcher.php?username=XXXXX

The header has this:

  <fetch>
    <userid>XXXX</userid>
    <static_id></static_id>
    <status>Success</status>
    <time>0.026</time>
  </fetch>
  <params>
    <request_id>62579521</request_id>
    <user_id>XXXX</user_id>
    <time_generated>1669542507</time_generated>
    <static_id/>
    <ofp_layout>LIDO</ofp_layout>
    <airac>2211</airac>
    <units>kgs</units>
  </params>

userid is my numeric simbrief id. Is this what it should be like so that the A310 can read it? Or should it be username? Or alias?

 

 

Edited by Johan217
Link to comment
Share on other sites

14 minutes ago, Johan217 said:

Mine does not generate an xml either. I created one by downloading https://www.simbrief.com/api/xml.fetcher.php?username=XXXXX

The header has this:

  <fetch>
    <userid>XXXX</userid>
    <static_id></static_id>
    <status>Success</status>
    <time>0.026</time>
  </fetch>
  <params>
    <request_id>62579521</request_id>
    <user_id>XXXX</user_id>
    <time_generated>1669542507</time_generated>
    <static_id/>
    <ofp_layout>LIDO</ofp_layout>
    <airac>2211</airac>
    <units>kgs</units>
  </params>

userid is my numeric simbrief id. Is this what it should be like so that the A310 can read it? Or should it be username? Or alias?

 

 

Afaik the A310 wont care whats in the header of the XML. We only need the username to access the xml and get you the correct fpl.

Once your system can access that file though, I´d think that the A310 can insert the fpl

Link to comment
Share on other sites

Hi,

several pilots in our group have try to charge Simbrief FPL, only the man who has the full Navigraph version (with Jeppesen maps) can use this function. People who have  the basic version (only Navdata) can't use this option.
Can you fix this ? The other aircarfts have not this limitation.
Thanks.

Edited by pacha35
Link to comment
Share on other sites

Perhaps the AIRAC has to be the exact same as the aircraft regardless of if the waypoints exists, which I think is 2211 in the A310? The simbrief.xml certainly contains the AIRAC version it's using. I'm using Navigraph AIRAC 2209 on a lapsed subscription currently, so maybe that it is?

Link to comment
Share on other sites

10 hours ago, M L said:

is there some requirement that something needed to be started or installed as admin to enable appropriate permissions to write this file?

The permissions for the work folder look strange. It kind of looks like it's read only but it is not. Drilling down to permissions show that my user (the one I run the game with) has full permissions. In addition - the game can clearly write simbrief.ini in the same directory so there is not a permissions issue.

Final point I think is that the retrieved xml is what the call to simbrief from the FMC would load as a fllightplan so really, lack of simbrief.xml is a symptom of the pending failure rather than a cause.

Link to comment
Share on other sites

At home, FS2020 has its Official and Community folders on a drive other than C:( which contains the technical files of the simulator including ...localstate...) Couldn't the "pending" problem come from there?
NB: AIRAC is up to date on all my products.

Edited by pacha35
Link to comment
Share on other sites

1 hour ago, pacha35 said:

At home, FS2020 has its Official and Community folders on a drive other than C:( which contains the technical files of the simulator including ...localstate...)

In case this could be a factor: I confirm I have the same installation.

Link to comment
Share on other sites

Many things *could* be but as I mention above, the a310 is able to write simbrief.ini whenever I change the username in the ACARS.

FWIW I'm on a Steam install with "...\work" on C drive and main install is on E with community in that hierarchy

Link to comment
Share on other sites

I have tried to run FS in normal mode (not admin) : it's the same thing.
But there is another problem with the ACARS page : if we want to obtain ATIS message, the FMS doesnot work after : it's blocked.
I think this is a similar problem that "pending".

Link to comment
Share on other sites

1 hour ago, pacha35 said:

I have tried to run FS in normal mode (not admin) : it's the same thing.
But there is another problem with the ACARS page : if we want to obtain ATIS message, the FMS doesnot work after : it's blocked.
I think this is a similar problem that "pending".

Yeah, that is a well known bug with the ATIS, I advise against using it. It´s already fixed on the official Beta Build in MSFS

Link to comment
Share on other sites

1 hour ago, gumbyger said:

Yeah, that is a well known bug with the ATIS, I advise against using it. It´s already fixed on the official Beta Build in MSFS

I have the official normal MSFS (40th, 2022 11 11) and the two bugs are inside (Pending and ATIS)

Link to comment
Share on other sites

7 hours ago, gumbyger said:

It´s already fixed on the official Beta Build in MSFS

That's a bit generous 🙂 as the fix was to remove the option all together from the MCU and just let the EFB do it.

I see the beta build rolled out to all in MSFS now, so curious to see if it fixes it for everyone as 'Fixed SimBrief Import' is still in the release notes, despite it not fixing it for anyone (that had an issue to begin with anyway).

I'll try again, as maybe the A310 updates between the beta and the release version.

Edited by fearlessfrog
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...