Jump to content

AN225 AP not working correctly

Oliver Gibbons

Recommended Posts


Please note that the AP is not working properly after the last update.

After take off, when you are climbing, the AP works how it is supposed to do so, but when you are about to reach your Cruise FL, the aircraft stop to follow your route and/or does not maintein the altitude.

This 2 issues affect the rest of the flight.

I used the AP with NAV option to follow my planned route. 

This didn't happened before tue update.

Now it is imposible to do a complete flight.

Awaiting your prompt answer 

Link to comment
Share on other sites


Sorry for my bad english but it is not my native languange.

The version before 1.0.5. was working fine and I did not experimented any issues regarding the AP.
After this update I started to notice that the AP do not follow the planned route and also do not maintein the selected altitude.
I think the altitude matter is due to the aircraft being to sensitive to the winds. (That is another thing that I want to highlight. Do I have to create another topic for it?)  

Ending.. The issue is that the AP does not follow the route or maintein the altitude after you reach your cruise altitude or maybe after a few minutes after engaged it (? 

Do you need me to provide some pictures or maybe a video about this?

Thank you,


Link to comment
Share on other sites



Sure, here they are:

They are in sequence, first how I had the AP configured and the at the Top Left, how the plane started to drift.

Also you will see the altitude issue that I mentioned before (Watch the VS) FL280:



The AP contanstly trying to go back to the path




Cant maintain the altitude, the VS is -1200 but then started to climb up again 


Link to comment
Share on other sites


Just did a quick flight in the AN again and it worked without a problem for me.

From your screenshots I can see that you didnt turn on the autothrust, which probably explains the over/undershooting of the altitude and maybe even the LNAV issues.


So could you please try again with autothrust enabled? 😄

Link to comment
Share on other sites



I just tried with the AT on and still have the same issues 😞

Do you think a re-install will fix these issues? Could it a problem for me only?

What else I could do to fix it?

thank for your support so far!


Link to comment
Share on other sites

  • 2 weeks later...



I do not know what is causing this issue but I also have all the assistances turned off.

The Flight Plan it is correctly loaded from In Game FP and honestly its fine until I reach my cruise level. After that, the plane starts to drift and do not follow the route correctly.

I thought it was that the plane it is very sensible to the winds (too much for me) but I found that it does even with 0 knt wind.

It is impossible now to do a full flight for me and It is a shame because I really liked it.

I need a solution:(

Link to comment
Share on other sites

The only other solution I can give you is to try it with an empty community folder as there maybe is a plugin that is doing weird things with the plane. Also maybe some special bindings you did in the options menu?

What you also could try is to disconnect your hardware during cruise to make sure that a noisy axis isnt interferring with it.

Link to comment
Share on other sites



I tried the way you said (disconnecting the hardwares) and also running the sim with the Community folder empty but the issues still there.

I also tested it with the Modern Flight Model mode and guess what? The plane is a lot better with this Mode, the issues still but they are not that bad as they were with the other flight model.

In my opinion.. the cruise altitude issue is due to the trim sensitivity plus the strong winds. The AP is slow to react to the altitude changes produced by the winds and the trim has to much sensitivity to do small or soft corrections. 

This could be solved by giving her a little bit more trim to play with and also reducing the effect to the plane.

The plane not following the route or drifting from the path is due to a bug with the AP or the GPS. Could be that the AP is slow to react or "fell asleep" or the GPS not working properly after sometime.

What else we could try? I will record a video tonight to show you the situation.

Edited by Oliver Gibbons
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...