Jump to content

Thrustmaster TCA Airbus Edition Thrustlever configuration


Maximilian Schmidt
 Share

Recommended Posts

  • Administrators

So to all having throttle calibration issues / if you know others who have it please let them know. We have made a fix code side but as a temporary workaround on TCA units:

Paths:
MS Store version: C:\Users\yournamehere\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\microsoft-aircraft-a310-300\work

Steam: C:\Users\yournamehere\AppData\Roaming\Microsoft Flight Simulator\Packages\microsoft-aircraft-a310-300\work

Steps
Locate your ThrottleConfiguration.ini file, open it and set both reverse_idle entries to a value that is 0.05 less than your idle value. 
Example: 
[throttle_common]
reverse_on_axis = true

[throttle_axis_1]
reverse_full = -1.000000
reverse_idle = -0.200000 -> Change to -0.45 because (idle is -0.39 - 0.05 = -0.45)
idle = -0.396667
toga = 1.000000

[throttle_axis_2]
reverse_full = -1.000000
reverse_idle = -0.200000 -> Change to -0.45 because (idle is -0.39 - 0.05 = -0.45)
idle = -0.395569
toga = 1.000000
 

  • Like 1
  • Thanks 2
Link to comment
Share on other sites

59 minutes ago, iniBuilds said:

So to all having throttle calibration issues / if you know others who have it please let them know. We have made a fix code side but as a temporary workaround on TCA units:

Paths:
MS Store version: C:\Users\yournamehere\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\microsoft-aircraft-a310-300\work

Steam: C:\Users\yournamehere\AppData\Roaming\Microsoft Flight Simulator\Packages\microsoft-aircraft-a310-300\work

Steps
Locate your ThrottleConfiguration.ini file, open it and set both reverse_idle entries to a value that is 0.05 less than your idle value. 
Example: 
[throttle_common]
reverse_on_axis = true

[throttle_axis_1]
reverse_full = -1.000000
reverse_idle = -0.200000 -> Change to -0.45 because (idle is -0.39 - 0.05 = -0.45)
idle = -0.396667
toga = 1.000000

[throttle_axis_2]
reverse_full = -1.000000
reverse_idle = -0.200000 -> Change to -0.45 because (idle is -0.39 - 0.05 = -0.45)
idle = -0.395569
toga = 1.000000
 

Good evening I also have TCA airbus and I am not understood exactly what to do sorry for my English I am French

Link to comment
Share on other sites

3 hours ago, iniBuilds said:

So to all having throttle calibration issues / if you know others who have it please let them know. We have made a fix code side but as a temporary workaround on TCA units:

Paths:
MS Store version: C:\Users\yournamehere\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\microsoft-aircraft-a310-300\work

Steam: C:\Users\yournamehere\AppData\Roaming\Microsoft Flight Simulator\Packages\microsoft-aircraft-a310-300\work

Steps
Locate your ThrottleConfiguration.ini file, open it and set both reverse_idle entries to a value that is 0.05 less than your idle value. 
Example: 
[throttle_common]
reverse_on_axis = true

[throttle_axis_1]
reverse_full = -1.000000
reverse_idle = -0.200000 -> Change to -0.45 because (idle is -0.39 - 0.05 = -0.45)
idle = -0.396667
toga = 1.000000

[throttle_axis_2]
reverse_full = -1.000000
reverse_idle = -0.200000 -> Change to -0.45 because (idle is -0.39 - 0.05 = -0.45)
idle = -0.395569
toga = 1.000000
 

Thanks for the help, now it works like a charm.

Link to comment
Share on other sites

58 minutes ago, corsica002b said:

You can explain exactly what to do please

No problem.

First of all, make sure that you have activated the option "Reverse on Throttle Axis" in the EFB.

Next, start the option "Calibrate Thrust Levers" in the EFB and configure your thrustlever with "Full Reverse Position", "Idle Position" and "Toga". Save this calibration.

Now go to the following path if you bought MSFS from the MS Store: 

C:\Users\YOUR USERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\microsoft-aircraft-a310-300\work

And the following path if you bought MSFS via Steam: 

C:\Users\YOUR USERNAME\AppData\Roaming\Microsoft Flight Simulator\Packages\microsoft-aircraft-a310-300\work.

and open the "ThrottleConfiguration.ini". There you enter -0.05 for "throttle_axis_1" under the item "reverse_idle" for the value you have for "idle". For example, if "idle" is -0.50, then enter -0.55 for "reverse_idle". Do the same for "throttle_axis_2". Note that the value of "throttle_axis_1" does not have to correspond to the values of "throttle_axis_2", but it can.

Then save this file and reload the aircraft, you do not have to close the simulator, it is sufficient to restart the flight via the ESC menu or to start a new flight via the main menu.
Now your thrust levers should work.

I have not changed the axis calibration in the MSFS settings.
I have attached all the settings and files here, if you have any further questions just let me know, I can also record a short video.

Kind regards
Maximilian

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Aucun problème.

Tout d'abord, assurez-vous que vous avez activé l'option "Reverse on Throttle Axis" dans l'EFB.

Ensuite, lancez l'option "Calibrer les leviers de poussée" dans l'EFB et configurez votre levier de poussée avec "Full Reverse Position", "Idle Position" et "Toga". Sauvegardez cette calibration.

Maintenant, allez au chemin suivant si vous avez acheté MSFS sur le MS Store : 

C:\Users\YOUR USERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\microsoft-aircraft-a310-300\work

Et le chemin suivant si vous avez acheté MSFS via Steam : 

C:\Users\YOUR USERNAME\AppData\Roaming\Microsoft Flight Simulator\Packages\microsoft-aircraft-a310-300\work.

et ouvrez le fichier "ThrottleConfiguration.ini". Là, vous entrez -0,05 pour "throttle_axis_1" sous l'élément "reverse_idle" pour la valeur que vous avez pour "idle". Par exemple, si "idle" est de -0,50, entrez -0,55 pour "reverse_idle". Faites de même pour "throttle_axis_2". Notez que la valeur de "throttle_axis_1" ne doit pas nécessairement correspondre aux valeurs de "throttle_axis_2", mais c'est possible.

Ensuite, sauvegardez ce fichier et rechargez l'avion, vous n'avez pas besoin de fermer le simulateur, il suffit de redémarrer le vol via le menu ESC ou de commencer un nouveau vol via le menu principal.
Maintenant vos leviers de poussée devraient fonctionner.

Je n'ai pas changé la calibration des axes dans les paramètres MSFS.
J'ai joint tous les paramètres et fichiers ici, si vous avez d'autres questions, faites-le moi savoir, je peux aussi enregistrer une courte vidéo.

Cordialement
Maximilian

Sensitivity.jpg

ThrottleConfiguration.ini

  • iniBuilds 1
Link to comment
Share on other sites

16 hours ago, iniBuilds said:

So to all having throttle calibration issues / if you know others who have it please let them know. We have made a fix code side but as a temporary workaround on TCA units:

Paths:
MS Store version: C:\Users\yournamehere\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\packages\microsoft-aircraft-a310-300\work

Steam: C:\Users\yournamehere\AppData\Roaming\Microsoft Flight Simulator\Packages\microsoft-aircraft-a310-300\work

Steps
Locate your ThrottleConfiguration.ini file, open it and set both reverse_idle entries to a value that is 0.05 less than your idle value. 
Example: 
[throttle_common]
reverse_on_axis = true

[throttle_axis_1]
reverse_full = -1.000000
reverse_idle = -0.200000 -> Change to -0.45 because (idle is -0.39 - 0.05 = -0.45)
idle = -0.396667
toga = 1.000000

[throttle_axis_2]
reverse_full = -1.000000
reverse_idle = -0.200000 -> Change to -0.45 because (idle is -0.39 - 0.05 = -0.45)
idle = -0.395569
toga = 1.000000
 

 

Sadly this didn't work for me. 

Before, my Throttle_axis_1 idle point was -0.414307, which I've now changed to add the extra .05 to 0.464307. The same goes for throttle_axis_2, which before was 0.454419 to which I've now changed to -0.454419.

It leaves my throttle in half the reverse detent. - I have to have my throttle at the CLB position (I use the TM Airbus Throttle Quad) to keep myself at idle.

Screenshot_13.png

Link to comment
Share on other sites

Guys , simple fix for this issue is , set reverse_idles = (value of idle)-1, so if it is -0.6785, then your values would be reverse_idle = -0.68785.....

fixed the issue and also complete a successful flight from New Delhi to London ,Heathrow on this aircraft. Yes, I believe that with future updates the aircraft will become smoother.

Link to comment
Share on other sites

Allen,

The values from Maximilian Schmidt above worked for me. I took his data and updated my throttleconfiguration.ini:

[throttle_common]
reverse_on_axis = true

[throttle_axis_1]
reverse_full = -1.000000
reverse_idle = -0.540173
idle = -0.490173
toga = 1.000000

[throttle_axis_2]
reverse_full = -1.000000
reverse_idle = -0.540173
idle = -0.487000
toga = 1.000000

Brgds

Juergen

Brgds

Juergen Mader

Link to comment
Share on other sites

Hi all

 

Had similar issues - the bindings for the A310 work if you use the throttle axis as “Throttle 0-100%”


If you have the Fenix A320 the throttle axis is “Throttle”. 
 

It doesn’t work when you have set up it as “Throttle” axis, so save different binding profiles and change it to the “Throttle 0-100%” axis is the way to go here…

Cheers,

Chen

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...