Jump to content

Big Performance Issues


Recommended Posts

Hey, just got the plane from MSFS Marketplace and I absolutely love it, but I'm seeing unacceptably bad performance when trying to fly the plane or even taxi it.

Preface: I play on 1920x1080 @ 60 Hz with V-Sync and AMD FreeSync Premium so my stable framerate is at 60 FPS.

So, first off there's a real big problem. Whenever I start from a parking spot, have done the checklists and started her up to begin taxiing to the runway, my framerate starts to gradually decrease the further I taxi from the parking spot, and by the time I'm at the runway the framerate will plummet all the way down to 2 FPS (By this time the plane is already uncontrollable and the whole sim has become very unresponsive.). If I open the pause menu the framerate will persist at the same low value even though the sim is now paused. I can Alt + Tab out of the game and there's zero latency there in the transition and Windows is working just fine. If I then go back to MSFS and exit to the game's main menu, the framerate will return back to 60 FPS, no problem. With any other plane these issues aren't present and I own a good variety of 3rd party planes, plus I have the Premium Deluxe Edition of the sim.

I've also tried stopping while taxiing, and say for example, if the frames have dropped to 20 FPS by then, as soon as I stop the plane the framerate will stay at that level and no longer decrease, but neither does it increase. Of course there's fluctuation going on, but it will stay roughly at the same very low FPS regardless. Then I've tried turning off the tablet (EFB), switching different systems off on the plane, all the way to shutting the plane down completely and turning absolutely everything off, and the framerate will still stay bogged down. Once again, even if I open the pause menu, the framerate won't rise. If I fire the plane up again and start moving the framerate will start degrading once I move. I've never experienced something like this before, and I've owned MSFS 2020 almost from its launch and have hundreds of hours in the sim. It's almost as if something keeps stacking up in the memory, like a memory leak. I'll need to do some testing with performance overlays to see what's going on, but I can tell by the sound of my fans, or by the lack of, that there's no abnormal stress on the GPU or CPU.

Then the second scenario I tried. Starting at the end of the runway with everything running already, now I get around 40 FPS, I put in half flaps, slam the throttle and takeoff, the FPS will remain at this 40 FPS level and will continue doing so even when I'm high off the ground and cruising. I can also change the weather from snow cover with clouds to clear skies without snow or the time of day to anything and see no change in the FPS.

I have no scenery modifications installed and this has happened on any location I've tried and if I change planes to say Got Friends PZL-104 Wilga or just about anything, I have no such issues and I have a stable 60 FPS. This is clearly isolated to this particular plane and I have no idea what could cause this.


My specs are:

ASUS ROG Strix B550-F GAMING motherboard

AMD Ryzen 7 5800X

AMD Radeon RX 7900 XT (PowerColor Hellhound)

32 Gb (2x16) Kingston Fury Renegade @ 3600 Mhz


MSFS is installed on a SATA SSD that's separate from the NVMe SSD where the OS resides. I'm on Windows 10 and run the game in DirectX 11. I tried DX 12 also, but no difference, only buggy graphics such as patches of missing ground textures and slow loading of the environmental textures in general due to the "Beta" nature of DX 12 in MSFS. My graphics settings are on the High-End preset with nothing changed. I can of course take a screenshot of them, if needed.

But yeah, as you can see, my setup is more than adequate and such issues should not be present. My drivers are all up to date and I play a lot of different games, including games like Cyberpunk 2077 with ray tracing and absolutely stunning graphics that run buttery smooth.

I not only love the plane you've modelled, but I really love Warhawks in general, especially the F-models, so I'm really bummed out by having such issues. For me 40 FPS is basically unplayable, as I absolutely hate stuttering, let alone a constant PowerPoint presentation. Not to mention, that a product is a product and this is unexpected behaviour from said product.

Lastly, I've applied to move my purchase to the iniBuilds store and we'll see if that makes a difference. I hadn't realized that guns and such aren't present in the MSFS Marketplace version, but that's on me, lesson learned.

Link to comment
Share on other sites

Ok, so I took screens of the issue with AMD's overlay and deliberately captured the screens so that Steam overlay's FPS counter is visible also.


From the images you can see the starting position with everything still in default state, just spawned in, then after everything powered up (except transponder, which I forgot) and there's no issues between either. Then when I start rolling you can see how the FPS starts to deteriorate rapidly and the frametime increasing. Interestingly enough you can see both GPU and CPU utilization actually dropping, which to me would indicate that there's something in-game starting to limit the FPS rather than hardware getting overloaded by something. Feel free to correct me if I'm wrong about this, but this is just my logical thinking and assumptions. Then in the end you can see how the FPS is restored when returning to the main menu.

Link to comment
Share on other sites

Hey again, an update on this. I genuinely have no idea what's going on, but now I started from parking, rolled to the runway and took off. All with a beautifully stable framerate. One thing I did do was skip doing the checklist and just start her up on my own. I'm also on a wired controller now instead of a wireless one. I connected my wireless controller and did some inputs also to see if it would cause problems, but it had no effect, everything was stable.

Here's a shot from the air with overlays:image.thumb.png.633bf8eff22d47bef4f23bc83e52fc51.png

Now I'm afraid to end the flight. The plane is phenomenal.



I ask not to close this thread yet, as issues might arise later still and I will post an update after some time if the problem just "disappeared". 

Link to comment
Share on other sites

Yeah... So I landed and we're back at it again. About the time the tires hit the runway it went downhill from there. Even changed the time of year and weather, including temperature, but to no effect.



Also, I've never got the fuel indicator to work, I've flipped the switch to the correct tank being used and all that changes is the amperage, the fuel gauge doesn't budge.

Link to comment
Share on other sites

Today I once again started from parking and the FPS bogs down the further I roll once again, from the get go, no lucky strike today.


Also, excuse me for my stupidity with the fuel gauge, it only shows the main fuselage tanks and not the wing tanks. As if it didn't say so on the gauge itself, duh. And the gauges for wing tanks are on the floor, with the switch controlling their respective lights, hence the abbreviation LTS on the switch label.

Link to comment
Share on other sites

  • 3 weeks later...

Hello, an update on this. A small while after the last post I decided to open a ticket directly to support and got a reply that all the previous info had been passed on to the dev team.

But, that's a side note as I've now found the cause of this and it's snow. Here you have the exact same everything, first with snow and then without, temperature remains unchanged.





More precisely it's something to do with the plane rolling on the ground while snow level is >0, as I remember from my previous tests that I started the flight with no snow cover, changed weather, including snow and it wasn't until the tyres hit the pavement that the FPS started bogging down, in the air everything was fine.

I'll also send an update email to my ticket with this info.


Link to comment
Share on other sites

  • 3 weeks later...
This topic is now closed to further replies.
  • Create New...